Skyward Outage - Maintenance Release Install
Incident Report for Wayzata Public Schools
Resolved
The Skyward Maintenance Release has been installed. Both Skyward Student and Skyward HR/Fin are back up and running.
Posted 4 months ago. Feb 11, 2018 - 08:17 CST
Identified
ISCorp, the company that host our instances of Skyward student and Skyward Hr/Fin, is installing the February 2018 Release through 6:00 p.m. Saturday, February 10th.

All Skyward systems will be down during this installation time.
Posted 4 months ago. Feb 09, 2018 - 19:28 CST