Phone Service Disruption
Incident Report for Wayzata Public Schools
Resolved
Incoming phone service and PA systems are now operational.

Thank you for your patience and understanding.
Posted about 1 month ago. Jan 22, 2018 - 14:47 CST
Identified
We are receiving reports that inbound calls are not being received. School PA systems are also experiencing service disruptions.

We are looking into the issue and will provide an update when more details are available.
Posted about 1 month ago. Jan 22, 2018 - 13:57 CST