Google Docs - Issues Remain
Incident Report for Wayzata Public Schools
Resolved
From the Google Suites Status Dashboard:

Google Docs service has already been restored for some users, and we expect a resolution for all users in the near future. Please note this time frame is an estimate and may change.
Posted 6 months ago. Nov 15, 2017 - 16:11 CST
Monitoring
From the Google Suites Status Dashboard:

Google is aware of a problem with Google Docs affecting a significant subset of users. The affected users are unable to access Google Docs. We will provide an update by 11/15/17, 4:30 PM detailing when we expect to resolve the problem. Please note that this resolution time is an estimate and may change.
Posted 6 months ago. Nov 15, 2017 - 15:47 CST