Google Apps not functioning for Wayzata Public Schools
Incident Report for Wayzata Public Schools
Resolved
Google Apps services have been restored for Wayzata Public Schools
Posted 9 months ago. Dec 07, 2017 - 12:49 CST
Identified
Google Apps are currently down for Wayzata Public Schools.

Currently an ETA for resolution is unknown, but we will send status updates on the situation as they become available.
Posted 9 months ago. Dec 07, 2017 - 12:31 CST