Google Docs - Captcha Issues
Incident Report for Wayzata Public Schools
Resolved
Google Docs is now operational and fully functional.
Posted 3 months ago. Nov 15, 2017 - 15:33 CST
Identified
Currently Google Docs is not available and users are encountering a Captcha log in. We are aware of issue and are monitoring Google Apps. We will provide an update when we know more.
Posted 3 months ago. Nov 15, 2017 - 15:21 CST